.NET Framework - DotNetFx 4.0 won't install

Asked By Jerry on 14-Apr-10 04:59 PM
DotNetFramework 4.0 Final (Client or Full) will not install in Windows XP
Pro w/SP3. Neither did the last/previous beta I tried. I was hoping the
final would solve the problem; that is why I delayed mentioning the problem.

I did have an earlier version installed when the incident started and
thinking it was part of the problem I uninstalled it. Made no difference.

The install routine, either Client of Full, starts OK, then I get a box and
beside the big red X a message: Setup has detected that this computer does
not meet the requirements to complete this operation. The following blocking
issues must be resolved before you can proceed.

BLOCKING ISSUES: Cannot install the .NET Framework 4 Client Profile. Other
applications on your computer are not compatible with this program. For more
information, see Release Notes.

The Release Notes and/or Readme provide no guidance or help in solving the
problem.

I know it is not a hardware problem as I have installed this DotNetFramework
on this same hardware in the other operating systems: XP Pro x64 w/SP2, Win7
32-bit, and Win7 64-bit. Also booted the XP Pro w/SP3 version in Safe Mode
and tried to install - no luck, same error message.

When the problem occured with the beta version I went so far as to use
DotNetFx cleanup_tool and had it uninstall ALL versions that were installed.
I then went through the process of re-installing all versions from DotNetFx
1.0 to 3.5 SP1 before trying 4.0 beta again - made no difference.

So, I would appreciate any and all help/comments/suggestions that may solve
this problem.




Gregory A. Beamer replied to Jerry on 16-Apr-10 12:58 AM
Find the uninstall notes for the CTP you previously had installed and make
sure you have completely removed all of the bits correctly. Many of the CTPs
require some work to get the RTM installed after they have been placed on a
machine.

--
Peace and Grace,
Greg

Twitter: @gbworld
Blog: http://gregorybeamer.spaces.live.com

************************************************
|    Think outside the box!                        |
************************************************
Mehmet Salim replied to Jerry on 04-Jun-10 07:16 AM
Hi,

If you extracted dotNetFx40_Full_x86_x64.exe and run directly setup.exe, you might get this error.



The other problem,

Before run dotNetFx40_Full_x86_x64.exe, you should remove all portable drives USB, SDCARD etc.



I solved like that. My OS: XP SP3